Wireshark-dev: Re: [Wireshark-dev] Cmake and RPM
From: João Valverde <[email protected]>
Date: Wed, 17 Aug 2016 11:29:20 +0100

On 08/17/2016 10:39 AM, Jonne Zutt wrote:
The "File listed twice" is a known issue I've read, and only a warning.
For the Installed (but unpackaged) file, I've added the following to the
%files sections of the rpm spec:
%exclude %{_libdir}/pkgconfig

Hurray!
Package successfully built in
/export/home/jzutt/wireshark/wireshark/packaging/rpm/RPMS.

 38M -rw-rw-r-- 1 jonne jonne  38M Aug 17 04:34
packaging/rpm/RPMS/x86_64/wireshark-2.3.0-1.x86_64.rpm
3.4M -rw-rw-r-- 1 jonne jonne 3.4M Aug 17 04:34
packaging/rpm/RPMS/x86_64/wireshark-qt-2.3.0-1.x86_64.rpm

I will test these rpms tomorrow. I wonder if there is anything I can do
to help improve wireshark related to this mail thread, or is my
distribution/system considered old or unsupported? Or maybe I've given
sufficient details for others?
No, not too old, Fedora 20 should pose no issues.

I will check the configure issue you faced. If you think it's a bug (it probably is, with some incomplete tests for the qtchooser CLI interface) you might still want to open a bug report at bugs.wireshark.org and then submit a patch to Gerrit.
https://wiki.wireshark.org/Development/SubmittingPatches

Thanks for testing this and reporting back.