Wireshark-dev: Re: [Wireshark-dev] Current C-Standard used in wireshark
From: Thomas Wiens <[email protected]>
Date: Sat, 2 Jan 2016 22:21:11 +0100
On 02.01.2016 21:40 Graham Bloice wrote:

> What version of Git do you have?  In your case it looks like git bash is
> being called and isn't able to execute tools\runlex.sh.
> 
> I have git version 2.6.4.windows.1 installed, and the only element of that
> installation on my path is "C:\Program Files\Git\cmd" which doesn't have
> the extra git msys utilities.  I think this is an option in the git
> install, however I install git using chocolatey so don't know what options
> the usual git installer may offer.  The choco install defaults to only
> gitinstall\cmd, but does have options for GitAndUnixToolsOnPath which adds
> gitinstall\bin which is what you have according to the build log:

It works!
I removed git from the path variable. I've had the path to Git\bin and
Git\cmd added.

I've got Git version 1.9.0. But as I remember, I've added the path for
myself manually, because I guessed that might fix the build problem with
wireshark, as it's remarked as "missing" when running CMake.

Conclusion:
- Wireshark build instructions are correct

For myself:
- Read the docs and double check each point
- Don't add unnecccesary path variables
- Try to understand how CMake works

Thanks for your help Graham