Wireshark-dev: Re: [Wireshark-dev] 0.99.6 build problems on Windows
From: "Anders Broman" <[email protected]>
Date: Mon, 8 Oct 2007 17:19:41 +0200
Hi,
Could the problem be that "old" gtk stuff is left?
Try the setup_clen target then setup then build.
Best regards
Anders

-----Ursprungligt meddelande-----
Från: [email protected]
[mailto:[email protected]] För
[email protected]
Skickat: den 8 oktober 2007 16:58
Till: [email protected]
Ämne: Re: [Wireshark-dev] 0.99.6 build problems on Windows

Sorry, but I came into this thread somewhere in the middle.  I didn't
see the original build output where your build stops.

If you have MS VC++ 6.0 installed, you don't need the SDK!!!
I have been building Ethereal/Wireshark for several years now with the
same MSVC installation!!

The only thing I've changed is the CYGWIN & WIRESHARK-WIN32-LIBS
versions.  I know when I changed from 99.2 to 99.6 that there were new
versions of CYGWIN tools & WIN32-LIBS required.  I also updated Python
to v2.4.

Over the next couple days, I'll rebuild my CYGWIN & WIRESHARK-WIN32-LIBS
environment.  I know there were a couple libraries that I couldn't use
the latest.

 
 
- Tim


> -----Original Message-----
> From: [email protected] 
> [mailto:[email protected]] On Behalf Of 
> Gianluca Varenni
> Sent: Friday, October 05, 2007 7:26 PM
> To: Developer support list for Wireshark
> Subject: Re: [Wireshark-dev] 0.99.6 build problems on Windows
> 
> You can still find the last Platform SDK that integrates with 
> Visual Studio
> 6 here
> 
> http://www.microsoft.com/msdownload/platformsdk/sdkupdate/psdk
> -full.htm
> 
> Have a nice day
> GV
> 
> 
> 
> ----- Original Message -----
> From: "Michael Lum" <[email protected]>
> To: "Developer support list for Wireshark" 
> <[email protected]>
> Sent: Friday, October 05, 2007 3:40 PM
> Subject: Re: [Wireshark-dev] 0.99.6 build problems on Windows
> 
> 
> >I updated my cygwin installation but that didn't help.
> >
> > I followed the link for the MS Platform SDK but it states 
> VC 6.0 is not
> > supported:
> >
> > Development Tools. To build the C/C++ samples, you must have a C/C++
> > compiler. If you are using Microsoft Visual C/C++(r), run 
> it at least
> > once before installing the SDK. This will ensure that the 
> environment
> > variables are correctly configured. To build the Visual 
> Basic samples,
> > you must have Microsoft Visual Basic(r). This SDK does not support
> > working with Microsoft Visual C/C++(r), 6.0 as support for 
> VC 6.0 has
> > ended. The last SDK that will work with VC 6.0 is the February 2003
> > Edition, you can order a CD on the fulfillment site. Side by side
> > installations are not supported.
> >
> > So unfortunately I'm still stuck.
> > I have tried, clean, distclean, setup, all, again but to no avail.
> >
> > Thanks.
> >
> > --
> > Michael Lum                   Principal Software Engineer
> > 4600 Jacombs Road             +1.604.276.0055
> > Richmond, B.C.
> > Canada V6V 3B1
> > UTStarcom Canada, Inc.
> > CDMA Division
> >
> >
> >> -----Original Message-----
> >> From: [email protected]
> >> [mailto:[email protected]] On Behalf Of
> >> Graham Bloice
> >> Sent: October 5, 2007 2:52 AM
> >> To: Developer support list for Wireshark
> >> Subject: Re: [Wireshark-dev] 0.99.6 build problems on Windows
> >>
> >> Michael Lum wrote:
> >> > Okay, here is the INCLUDE value:
> >> >
> >> >
> >> 
> INCLUDE=C:\PROGRA~1\MICROS~3\VC98\ATL\INCLUDE;C:\PROGRA~1\MICROS~3\VC9
> >> > 8\
> >> > INCLUDE;C:\PROGRA~1\MICROS~3\V
> >> >
> >> 
> C98\MFC\INCLUDE;C:\PROGRA~1\MICROS~3\VC98\ATL\INCLUDE;C:\PROGRA~1\MICR
> >> > OS
> >> > ~3\VC98\INCLUDE;C:\PROGRA~1\MI
> >> >
> >> 
> CROS~3\VC98\MFC\INCLUDE;C:\PROGRA~1\MICROS~3\VC98\ATL\INCLUDE;C:\PROGR
> >> > A~
> >> > 1\MICROS~3\VC98\INCLUDE;C:\PRO
> >> > GRA~1\MICROS~3\VC98\MFC\INCLUDE;
> >> >
> >> >
> >> That just seems to have the standard VC6 includes, replicated
> >> 3 times for good measure!  There is no sign of the SDK 
> includes there.
> >> > Has the way you setup your environment changed since 0.99.4?
> >> > Everything builds with 0.99.4.
> >> >
> >> > Thanks
> >> >
> >> >
> >> Personally, when I used VC6 I always built with the SDK 
> includes.  The
> >> VC6 toolchain and standard includes were so old it was
> >> essential, certainly for my day job.  However, I see the
> >> Developers Guide claims that it isn't required.  I'd be
> >> interested to know if the buildbot (which still uses VC6) has
> >> the SDK installed.  Maybe Gerald can comment.
> >>
> >> There have been a number of changes in the makefiles since
> >> 0.99.4 so that might account for your difficulties.
> >>
> >> --
> >> Regards,
> >>
> >> Graham Bloice
> >>
> >> _______________________________________________
> >> Wireshark-dev mailing list
> >> [email protected]
> >> http://www.wireshark.org/mailman/listinfo/wireshark-dev
> >>
> > _______________________________________________
> > Wireshark-dev mailing list
> > [email protected]
> > http://www.wireshark.org/mailman/listinfo/wireshark-dev 
> 
> _______________________________________________
> Wireshark-dev mailing list
> [email protected]
> http://www.wireshark.org/mailman/listinfo/wireshark-dev
> 
_______________________________________________
Wireshark-dev mailing list
[email protected]
http://www.wireshark.org/mailman/listinfo/wireshark-dev