Wireshark-dev: Re: [Wireshark-dev] 0.99.6 build problems on Windows
From: Graham Bloice <[email protected]>
Date: Mon, 08 Oct 2007 16:27:34 +0100
[email protected] wrote:
> Sorry, but I came into this thread somewhere in the middle.  I didn't
> see the original build output where your build stops.
>
> If you have MS VC++ 6.0 installed, you don't need the SDK!!!
> I have been building Ethereal/Wireshark for several years now with the
> same MSVC installation!!
>
> The only thing I've changed is the CYGWIN & WIRESHARK-WIN32-LIBS
> versions.  I know when I changed from 99.2 to 99.6 that there were new
> versions of CYGWIN tools & WIN32-LIBS required.  I also updated Python
> to v2.4.
>
> Over the next couple days, I'll rebuild my CYGWIN & WIRESHARK-WIN32-LIBS
> environment.  I know there were a couple libraries that I couldn't use
> the latest.
>
>   
The makefile.nmake "setup" target checks for the existence of the
required Cygwin tools, and updates the Win32libs automagically.

AFAIK, with the recent changes to the makefile, all you need to install
yourself is Cygwin & the MS toolchain, as detailed in the developers guide.

-- 
Regards,

Graham Bloice