Wireshark-dev: Re: [Wireshark-dev] pidl license question
From: Ulf Lamping <[email protected]>
Date: Sun, 12 Aug 2007 13:30:11 +0200
Joerg Mayer schrieb:
Samba's svn has made the switch from GPLv2 to GPLv3. While I don't see
any problem in including a GPLv3 tool (pidl) into the Wireshark repository
I have a question regarding the license of the generated dissectors. So
far the generated dissectors don't contain a license statement (nor a
copyright statement), nor does the README accompanying the tool. So my
question is: Can we still use the pidl tool from Samba to generate
source files for Wireshark?
I guess *using* GPLv3 tools is safe here, otherwise you couldn't even use the upcoming gcc. However, the safest bet is to simply ask them ;-)
Another thing would be to use code/data from GPLv3 samba, which is a 
problem as GPLv2 and v3 is *not* compatible. In addition: If the samba 
tools would start to include GPLv3 headers into the generated files, we 
must stop using them - or keep an older version!
Regards, ULFL