wnpa-sec-2023-04 · GNW dissector crash

Summary

Name: GNW dissector crash

Docid: wnpa-sec-2023-04

Date: January 18, 2023

Affected versions: 4.0.0 to 4.0.2, 3.6.0 to 3.6.10

Fixed versions: 4.0.3, 3.6.11

References:
Wireshark issue 18779

Details

Description

The GNW dissector could crash.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 4.0.3, 3.6.11 or later.