wnpa-sec-2022-04 · CSN.1 dissector crash

Summary

Name: CSN.1 dissector crash

Docid: wnpa-sec-2022-04

Date: February 10, 2022

Affected versions: 3.6.0 to 3.6.1, 3.4.0 to 3.4.11

Fixed versions: 3.6.2, 3.4.12

References:
Wireshark issue 17882
CVE-2022-0582

Details

Description

The CSN.1 protocol dissector could crash on some platforms. Discovered by Sharon Brizinov.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 3.6.2, 3.4.12 or later.