wnpa-sec-2021-14 · Modbus dissector crash

Summary

Name: Modbus dissector crash

Docid: wnpa-sec-2021-14

Date: November 17, 2021

Affected versions: 3.4.0 to 3.4.9, 3.2.0 to 3.2.17

Fixed versions: 3.4.10, 3.2.18

References:
Wireshark issue 17703
CVE-2021-39921

Details

Description

The Modbuss dissector could crash.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 3.4.10, 3.2.18 or later.