wnpa-sec-2019-22 · CMS dissector crash

Summary

Name: CMS dissector crash

Docid: wnpa-sec-2019-22

Date: December 4, 2019

Affected versions: 3.0.0 to 3.0.6, 2.6.0 to 2.6.12

Fixed versions: 3.0.7, 2.6.13

References:
Wireshark issue 15961
CVE-2019-19553

Details

Description

The CMS dissector could crash.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 3.0.7, 2.6.13 or later.