wnpa-sec-2019-20 · ASN.1 BER and related dissectors crash

Summary

Name: ASN.1 BER and related dissectors crash

Docid: wnpa-sec-2019-20

Date: July 17, 2019

Affected versions: 3.0.0 to 3.0.2, 2.6.0 to 2.6.9, 2.4.0 to 2.4.15

Fixed versions: 3.0.3, 2.6.10, 2.4.16

References:
Wireshark issue 15870
CVE-2019-13619

Details

Description

The ASN.1 BER and related dissectors could crash.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 3.0.3, 2.6.10, 2.4.16 or later.