wnpa-sec-2019-14 · GSS-API dissector crash

Summary

Name: GSS-API dissector crash

Docid: wnpa-sec-2019-14

Date: April 8, 2019

Affected versions: 3.0.0, 2.6.0 to 2.6.7, 2.4.0 to 2.4.13

Fixed versions: 3.0.1, 2.6.8, 2.4.14

References:
Wireshark issue 15613
CVE-2019-10894

Details

Description

The GSS-API dissector could crash. Discovered by Mateusz Jurczyk.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 3.0.1, 2.6.8, 2.4.14 or later.