wnpa-sec-2017-44 · DMP dissector crash

Summary

Name: DMP dissector crash

Docid: wnpa-sec-2017-44

Date: October 10, 2017

Affected versions: 2.4.0 to 2.4.1, 2.2.0 to 2.2.9, 2.0.0 to 2.0.15

Fixed versions: 2.4.2, 2.2.10, 2.0.16

References:
Wireshark issue 14068
CVE-2017-15191

Details

Description

The DMP dissector could crash. Discovered by the OSS-Fuzz project.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 2.4.2, 2.2.10, 2.0.16 or later.