wnpa-sec-2016-36 · NetScreen file parser crash

Summary

Name: NetScreen file parser crash

Docid: wnpa-sec-2016-36

Date: June 7, 2016

Affected versions: 2.0.0 to 2.0.3, 1.12.0 to 1.12.11

Fixed versions: 2.0.4, 1.12.12

References:
Wireshark issue 12396
CVE-2016-5357

Details

Description

The NetScreen file parser could crash. Discovered by iDefense Labs.

Impact

It may be possible to make Wireshark crash by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 2.0.4, 1.12.12 or later.