wnpa-sec-2016-11 · LLRP dissector crash

Summary

Name: LLRP dissector crash

Docid: wnpa-sec-2016-11

Date: February 26, 2016

Affected versions: 2.0.0 to 2.0.1, 1.12.0 to 1.12.9

Fixed versions: 2.0.2, 1.12.10

References:
Wireshark issue 12048
CVE-2016-2532

Details

Description

The LLRP dissector could crash. Discovered by Mateusz Jurczyk.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 2.0.2, 1.12.10 or later.