wnpa-sec-2015-06 · ATN-CPDLC dissector crash

Summary

Name: ATN-CPDLC dissector crash

Docid: wnpa-sec-2015-06

Date: March 4, 2015

Affected versions: 1.12.0 to 1.12.3

Fixed versions: 1.12.4

References:
Wireshark issue 9952
CVE-2015-2187

Details

Description

The ATN-CPDLC dissector could crash.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.12.4 or later.