wnpa-sec-2014-22 · NCP dissector crashes

Summary

Name: NCP dissector crashes

Docid: wnpa-sec-2014-22

Date: November 12, 2014

Affected versions: 1.12.0 to 1.12.1, 1.10.0 to 1.10.10

Fixed versions: 1.12.2, 1.10.11

References:
Wireshark issue 10552
Wireshark issue 10628
CVE-2014-8712
CVE-2014-8713

Details

Description

The NCP dissector could crash due to multiple issues.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.12.2, 1.10.11 or later.