wnpa-sec-2014-08 · Catapult DCT2000 and IrDA dissector crash

Summary

Name: Catapult DCT2000 and IrDA dissector crash

Docid: wnpa-sec-2014-08

Date: July 31, 2014

Affected versions: 1.10.0 to 1.10.8

Fixed versions: 1.10.9

References:
CVE-2014-5161
CVE-2014-5162

Details

Description

The Catapult DCT2000 and IrDA dissectors could underrun a buffer.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.10.9 or later.