wnpa-sec-2014-04 · MPEG file parser buffer overflow

Summary

Name: MPEG file parser buffer overflow

Docid: wnpa-sec-2014-04

Date: March 7, 2014

Affected versions: 1.10.0 to 1.10.5, 1.8.0 to 1.8.12

Fixed versions: 1.10.6, 1.8.13

References:
Wireshark issue 9843
CVE-2014-2299

Details

Description

The MPEG file parser could overflow a buffer. Discovered by Wesley Neelen.

Impact

It may be possible to make Wireshark crash or execute malicious code by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.10.6, 1.8.13 or later.