wnpa-sec-2012-21 · Wireshark STUN dissector crash

Summary

Name: Wireshark STUN dissector crash

Docid: wnpa-sec-2012-21

Date: August 15, 2012

Affected versions: 1.4.0 to 1.4.14, 1.6.0 to 1.6.9, 1.8.0 to 1.8.1

Fixed versions: 1.8.2, 1.6.10, 1.4.15

References: Wireshark bug 7569
CVE-2012-4292

Details

Description

The STUN dissector could crash. Reported by Laurent Butti.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.8.2, 1.6.10, 1.4.15 or later.