wnpa-sec-2011-19 · Wireshark ERF file parser vulnerability

Summary

Name: Wireshark ERF file parser vulnerability

Docid: wnpa-sec-2011-19

Date: November 1, 2011

Affected versions: 1.4.0 to 1.4.9, 1.6.0 to 1.6.2

Fixed versions: 1.6.3

References: Wireshark bug 6479

Details

Description

Huzaifa Sidhpurwala of Red Hat Security Response Team discovered a buffer overflow in the ERF file reader.

Impact

It may be possible to make Wireshark crash by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.6.3 or later.