wnpa-sec-2011-12 · Wireshark OpenSafety dissector vulnerability

Summary

Name: Wireshark OpenSafety dissector vulnerability

Docid: wnpa-sec-2011-12

Date: September 7, 2011

Affected versions: 1.6.0 to 1.6.1

Fixed versions: 1.6.2

References: Wireshark bug 6138
CVE-2011-3484

Details

Description

A large loop in the OpenSafety dissector could cause a crash.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.6.2 or later.