wnpa-sec-2011-05 · X.509if vulnerability in Wireshark

Summary

Name: X.509if vulnerability in Wireshark

Docid: wnpa-sec-2011-05

Date: April 14, 2011

Affected versions: {{ start_version }} up to and including {{ end_version }}

Fixed versions: 1.2.16

Related: wnpa-sec-2011-06 (DECT, NFS, and X.509if vulnerabilities in Wireshark version 1.4.0 to 1.4.4 )

Details

Description

Wireshark 1.2.16 fixes the following vulnerability:

  • The X.509if dissector could crash. (Bug 5754, Bug 5793)
    Versions affected: 1.2.0 to 1.2.15 and 1.4.0 to 1.4.4.

Impact

It may be possible to make Wireshark crash by injecting a series of malformed packets onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.2.16 or later.

If are running Wireshark 1.2.15 or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the X.509if dissector:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "X.509if" is un-checked.
    • Click "Save", then click "OK".