We're now a non-profit! Support open source packet analysis by making a donation.

wnpa-sec-2009-08 · Multiple vulnerabilities in Wireshark


Name: Multiple vulnerabilities in Wireshark

Docid: wnpa-sec-2009-08

Date: October 26, 2009

Affected versions: 0.10.10 up to and including 1.0.9

Fixed versions: 1.0.10



Wireshark 1.0.10 fixes the following vulnerabilities:

  • The RADIUS dissector could crash. (Bug 3578)
    Versions affected: 0.10.13 to 1.0.9, 1.2.0
  • The DCERPC/NT dissector could crash.
    Versions affected: 0.10.10 to 1.0.9, 1.2.0 to 1.2.2


It may be possible to make Wireshark crash remotely or by convincing someone to read a malformed packet trace file.


Upgrade to Wireshark 1.0.10 or later.

If are running Wireshark {{ end_version }} or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the affected dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "RADIUS" and "DCERPC" are all un-checked.
    • Click "Save", then click "OK".