Wireshark-dev: Re: [Wireshark-dev] error building wireshark-2.6.2 on RHEL 7.3
From: Michal Ruprich <[email protected]>
Date: Tue, 7 Aug 2018 14:04:47 +0200

Hi Shahar,


I maintain wireshark in RHEL-7 and I have the latest version in COPR if you don't want to build it yourself:

https://copr.fedorainfracloud.org/coprs/mruprich/wireshark-el7/


I was trying to build this on RHEL-7.5 and it works.


On 07/30/2018 02:43 PM, Shahar Keren (shkeren) via Wireshark-dev wrote:

Hi

I am trying to install latest stable release on my RH.

according to err log - 

/bin/c++    -fexcess-precision=fast  -DCXX__Wcomma_VALID -fPIE   -fexcess-precision=fast -Wcomma -o CMakeFiles/cmTryCompileExec4287660239.dir/src.cxx.o -c /tmp/build/CMakeFiles/CMakeTmp/src.cxx
c++: error: unrecognized command line option '-Wcomma'
gmake[1]: *** [CMakeFiles/cmTryCompileExec4287660239.dir/src.cxx.o] Error 1
gmake[1]: Leaving directory `/tmp/build/CMakeFiles/CMakeTmp'
gmake: *** [cmTryCompileExec4287660239/fast] Error 2

I do not see specific c++ requirements in dev guide lib reference.
stdout and stderr logs attached.

any advise ?

thanks,
Shahar​




___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <[email protected]>
Archives:    https://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
             mailto:[email protected]?subject=unsubscribe
Regards,
Michal