Wireshark-dev: Re: [Wireshark-dev] [Wireshark-commits] master 14824e6: Revert "Fixup: tvb_* ->
From: Dario Lombardo <[email protected]>
Date: Fri, 20 Jun 2014 16:42:03 +0200
On Fri, Jun 20, 2014 at 4:33 PM, Jeff Morriss <[email protected]> wrote:
> IOW the reason these functions were renamed was because a large portion of
> the time dissector-writers would use tvb_length() when they really should
> have been using tvb_reported_length().  By renaming the functions and adding
> a macro--which is listed as deprecated by checkAPIs--for backwards
> compatibility we can know which calls have yet to be audited/checked for
> correctness.  That is, the whole point is to *not* systematically replace
> tvb_length() but rather check each call and replace it with the correct one.

Well, thank you, I've got the point now.