Wireshark-dev: Re: [Wireshark-dev] dll compatibility between 1.1.3/4 and 1.0.6
From: Jaap Keuter <[email protected]>
Date: Mon, 30 Mar 2009 21:41:56 +0200
Hi,

Even though it *may* appear to work, there is no guarantee that it doesn't fail in subtle ways. So don't come whining when it doesn't work. That is all.
Thanx,
Jaap

wsgd wrote:
Ok, there is absolutely no warranty, but it could work.

I have a C++ plugin generated on 1.0.3, Visual C++ 2005 EE, Vista.
It works well on :
- 1.0.3, 1.1.4 generated on Visual C++ 2005 EE, Vista
- 1.0.5 from http://www.wireshark.org/ (so must be MSCV 6)



Olivier

Anders Broman a écrit :
Hi,

Basically only bug fixes goes to the 1.0.x branch http://wiki.wireshark.org/Development/ReleasePolicy
1.1.x branch is built with MSVC 2008 1.0.x with MSCV 6 + probably the 
API has changed, so no a pugin compiled with
1.0.6 not work with 1.1.x nor 1.2.0 when it’s released.

Regards

Anders

------------------------------------------------------------------------

*Från:* [email protected] [mailto:[email protected]] *För *Blazer, Doron
*Skickat:* den 30 mars 2009 14:40
*Till:* Developer support list for Wireshark
*Ämne:* [Wireshark-dev] dll compatibility between 1.1.3/4 and 1.0.6

Hi,

I understand there are 2 source code sets – stable and development.

The latest are 1.0.6 and 1.1.3/4(svn).

What is the relationship between the two?

Does 1.0.6 is the last svn of 1.1.2?

If I write a plugin for 1.1.3 should it fit for 1.0.7?

Thanks,

Doron