Wireshark-dev: Re: [Wireshark-dev] Problems building on Windows XP
From: Ulf Lamping <[email protected]>
Date: Tue, 15 Apr 2008 04:57:03 +0200
L. Mark Pilant schrieb:
I started with a fresh copy of Wireshark (to revision 25024) to a new
directory and a clean wireshark-win32-libs directory (I renamed the
"old" one to force fresh fetching of the files).  Then I did:

   nmake -f Makefile.nmake distclean
   nmake -f Makefile.nmake setup
   nmake -f Makefile.nmake

The distclean and setup went find.  However I'm getting the following
error trying to build Wireshark:

        xcopy C:\wireshark-win32-libs\adns-1.0-win32-05 adns.tmp /D /I /E /Y
0 File(s) copied
        copy adns_dll.dep adns.tmp\adns_win32\adns_dll
        1 file(s) copied.
        copy adns_dll.rc adns.tmp\adns_win32\adns_dll
        1 file(s) copied.
        cd adns.tmp\adns_win32\adns_dll
        set CFG=adns_dll - Win32 Release
        nmake /                   -f adns_dll.mak
LOC="-D_CRT_SECURE_NO_DEPRECATE -D_CRT_NONSTDC_NO_DEPRECATE"

Microsoft (R) Program Maintenance Utility Version 7.10.3077
Copyright (C) Microsoft Corporation.  All rights reserved.

        if not exist C:\wireshark-win32-libs\MSVC2003\adns mkdir
C:\wireshark-win32-libs\MSVC2003\adns
        copy adns_dll.dll C:\wireshark-win32-libs\MSVC2003\adns\adns_dll.dll
The system cannot find the file specified.
NMAKE : fatal error U1077: 'copy' : return code '0x1'
Stop.


It would appear the problem is no files were copied on the "xcopy" but
yet all the files are there.

Oh yes, I'm building under Visual Studio .NET 2003 with the appropriate
changes to config.nmake.  This was working up through revision 24594 when
I last did and SVN update.

Any ideas?
As there are known problems with the adns dll on builds other than MSVC6, I've very recently changed the build process to generate the adns_dll.dll and .lib on such systems (and just copy them on MSVC6 systems).
The xcopy in your case won't copy any files if they already existing 
(and correctly timestamped when I remember correct) - that's not the 
problem.
Do you have a adns.tmp dir in your WS sources?
Do you have a C:\wireshark-win32-libs\MSVC2003\adns?
Do you have C:\wireshark\adns.tmp\adns_win32\lib\adns_dll.dll?

The basic mechanism how it should work: copy adns sources to C:\wireshark\adns.tmp, patch the sources with MSVC2005EE stuff (maybe here's the problem - but I can't test this), copy generated dll and lib from C:\wireshark\adns.tmp\adns_win32\lib into C:\wireshark-win32-libs\MSVC2003\adns (compiler specific target dir), del adns.tmp dir.
Regards, ULFL