Wireshark-dev: [Wireshark-dev] Problems building on Windows XP
From: "L. Mark Pilant" <[email protected]>
Date: Mon, 14 Apr 2008 17:25:23 -0400
I started with a fresh copy of Wireshark (to revision 25024) to a new
directory and a clean wireshark-win32-libs directory (I renamed the
"old" one to force fresh fetching of the files).  Then I did:

   nmake -f Makefile.nmake distclean
   nmake -f Makefile.nmake setup
   nmake -f Makefile.nmake

The distclean and setup went find.  However I'm getting the following
error trying to build Wireshark:

        xcopy C:\wireshark-win32-libs\adns-1.0-win32-05 adns.tmp /D /I /E /Y
0 File(s) copied
        copy adns_dll.dep adns.tmp\adns_win32\adns_dll
        1 file(s) copied.
        copy adns_dll.rc adns.tmp\adns_win32\adns_dll
        1 file(s) copied.
        cd adns.tmp\adns_win32\adns_dll
        set CFG=adns_dll - Win32 Release
        nmake /                   -f adns_dll.mak
LOC="-D_CRT_SECURE_NO_DEPRECATE -D_CRT_NONSTDC_NO_DEPRECATE"

Microsoft (R) Program Maintenance Utility Version 7.10.3077
Copyright (C) Microsoft Corporation.  All rights reserved.

        if not exist C:\wireshark-win32-libs\MSVC2003\adns mkdir
C:\wireshark-win32-libs\MSVC2003\adns
        copy adns_dll.dll C:\wireshark-win32-libs\MSVC2003\adns\adns_dll.dll
The system cannot find the file specified.
NMAKE : fatal error U1077: 'copy' : return code '0x1'
Stop.


It would appear the problem is no files were copied on the "xcopy" but
yet all the files are there.

Oh yes, I'm building under Visual Studio .NET 2003 with the appropriate
changes to config.nmake.  This was working up through revision 24594 when
I last did and SVN update.

Any ideas?

Thanks in advance.

- Mark