wnpa-sec-2010-04 · DOCSIS vulnerabilities in Wireshark


Name: DOCSIS vulnerabilities in Wireshark

Docid: wnpa-sec-2010-04

Date: May 5, 2010

Affected versions: {{ start_version }} up to and including {{ end_version }}

Related: wnpa-sec-2010-03 (DOCSIS vulnerabilities in Wireshark version 0.9.6 to 1.0.12)

Fixed versions: 1.2.8

Related: wnpa-sec-2010-03 (DOCSIS vulnerabilities in Wireshark version 0.9.6 to 1.0.12)



Wireshark 1.2.8 fixes the following vulnerability:


It may be possible to make Wireshark crash by convincing someone to read a malformed packet trace file.


Upgrade to Wireshark 1.2.8 or later.

If are running Wireshark 1.2.7 or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the affected dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "DOCSIS" is un-checked.
    • Click "Save", then click "OK".
Enhance Wireshark

Riverbed is Wireshark's primary sponsor and provides our funding. They also make great products.

802.11 Packet Capture

Riverbed AirPcap
  • WLAN packet capture and transmission
  • Full 802.11 a/b/g/n support
  • View management, control and data frames
  • Multi-channel aggregation (with multiple adapters)

Learn More

Buy Now

Packet Analysis Made Easy

    SteelCentral Packet Analyzer Personal Edition graphs
  • Visually rich, powerful LAN analyzer
  • Quickly access very large pcap files
  • Professional, customizable reports
  • Advanced triggers and alerts
  • Fully integrated with Wireshark

Try Packet Analyzer PE FREE for 10 days

Buy Now