Join us June 15-20 for SharkFest'24 US, the official Wireshark Developer & User Conference

wnpa-sec-2010-04 · DOCSIS vulnerabilities in Wireshark

Summary

Name: DOCSIS vulnerabilities in Wireshark

Docid: wnpa-sec-2010-04

Date: May 5, 2010

Affected versions: 1.2.0 up to and including 1.2.7

Related: wnpa-sec-2010-03 (DOCSIS vulnerabilities in Wireshark version 0.9.6 to 1.0.12)

Fixed versions: 1.2.8

Details

Description

Wireshark 1.2.8 fixes the following vulnerability:

Impact

It may be possible to make Wireshark crash by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.2.8 or later.

If are running Wireshark {{ end_version }} or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the affected dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "DOCSIS" is un-checked.
    • Click "Save", then click "OK".