Huge thanks to our Platinum Members Endace and LiveAction,
and our Silver Member Veeam, for supporting the Wireshark Foundation and project.

wnpa-sec-2010-03 · DOCSIS vulnerabilities in Wireshark


Name: DOCSIS vulnerabilities in Wireshark

Docid: wnpa-sec-2010-03

Date: May 5, 2010

Affected versions: 0.9.6 up to and including 1.0.12

Fixed versions: 1.0.13



Wireshark 1.0.13 fixes the following vulnerability:


It may be possible to make Wireshark crash by convincing someone to read a malformed packet trace file.


Upgrade to Wireshark 1.0.13 or later.

If are running Wireshark {{ end_version }} or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the affected dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "DOCSIS" is un-checked.
    • Click "Save", then click "OK".