wnpa-sec-2010-03 · DOCSIS vulnerabilities in Wireshark

Summary

Name: DOCSIS vulnerabilities in Wireshark

Docid: wnpa-sec-2010-03

Date: May 5, 2010

Affected versions: {{ start_version }} up to and including {{ end_version }}

Fixed versions: 1.0.13

Related: wnpa-sec-2010-04 (DOCSIS vulnerabilities in Wireshark version 1.2.0 to 1.2.7 )

Details

Description

Wireshark 1.0.13 fixes the following vulnerability:

Impact

It may be possible to make Wireshark crash by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.0.13 or later.

If are running Wireshark 1.0.12 or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the affected dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "DOCSIS" is un-checked.
    • Click "Save", then click "OK".