Wireshark-dev: Re: [Wireshark-dev] [Wireshark-commits] rev 40549: /trunk/ /trunk/epan/dissector
From: Anders Broman <[email protected]>
Date: Mon, 16 Jan 2012 22:47:41 +0100
Pascal Quantin skrev 2012-01-16 22:39:
Hi,

Le 16/01/2012 22:36, Joerg Mayer a écrit :
On Mon, Jan 16, 2012 at 09:25:22PM +0000, [email protected] wrote:
http://anonsvn.wireshark.org/viewvc/viewvc.cgi?view=rev&revision=40549

User: etxrab
Date: 2012/01/16 01:25 PM

Log:
  From Pascal Quantin:
  Upgrade LTE RRC dissector to v10.4.0

  https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=6742

Directory: /trunk/epan/dissectors/
   Changes    Path                Action
   +48 -9     packet-lpp.c        Modified
   +9016 -1461 packet-lte-rrc.c    Modified

Directory: /trunk/epan/
   Changes    Path              Action
   +1 -1      CMakeLists.txt    Modified

Directory: /trunk/asn1/lpp/
   Changes    Path          Action
   +10 -0     lpp.cnf       Modified

Directory: /trunk/asn1/lte-rrc/
   Changes    Path                              Action
   +22 -4     EUTRA-InterNodeDefinitions.asn    Modified
   +947 -73   EUTRA-RRC-Definitions.asn         Modified
   +38 -3     EUTRA-UE-Variables.asn            Modified
   +147 -3    lte-rrc.cnf                       Modified
   +298 -6    packet-lte-rrc-template.c         Modified
Here is what I get on my OSX testsystem:

libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../.. -I../../../epan/dissectors -I../../../epan/dissectors/../.. -I../../../epan/dissectors/.. -I/usr/local/include -I/usr/local/include -I/usr/local/include -DPLUGIN_DIR=\"/usr/local/lib/wireshark/plugins/1.7.1\" -DINET6 -DG_DISABLE_DEPRECATED -DG_DISABLE_SINGLE_INCLUDES -DGTK_DISABLE_SINGLE_INCLUDES -no-cpp-precomp -D_FORTIFY_SOURCE=2 "-D_U_=__attribute__((unused))" -g -O2 -Wall -W -Wextra -Wdeclaration-after-statement -Wendif-labels -Wpointer-arith -Wno-pointer-sign -Wcast-align -Wformat-security -Wold-style-definition -I/usr/local/include -DGSEAL_ENABLE -D_REENTRANT -I/usr/local/include/gtk-3.0 -I/usr/local/include/atk-1.0 -I/usr/local/include/cairo -I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/pango-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/pixman-1 -I/usr/local/include/libpng15 -I/usr/X11/include -I/usr/X11/include/freetype2 -MT packet-lpp.lo -MD -MP -MF .deps/packet-lpp.Tpo -c ../../../epan/dissectors/packet-lpp.c  -fno-common -DPIC -o .libs/packet-lpp.o
../../asn1/lte-rrc/packet-lte-rrc-template.c:42:24: error: packet-lpp.h: No such file or directory
../../asn1/lte-rrc/packet-lte-rrc-fn.c: In function 'dissect_lte_rrc_T_ellipsoid_Point_r10':
../../asn1/lte-rrc/packet-lte-rrc-fn.c:17022: warning: implicit declaration of function 'dissect_lpp_Ellipsoid_Point_PDU'
../../asn1/lte-rrc/packet-lte-rrc-fn.c: In function 'dissect_lte_rrc_T_ellipsoidPointWithAltitude_r10':
../../asn1/lte-rrc/packet-lte-rrc-fn.c:17038: warning: implicit declaration of function 'dissect_lpp_EllipsoidPointWithAltitude_PDU'
../../asn1/lte-rrc/packet-lte-rrc-fn.c: In function 'dissect_lte_rrc_T_horizontalVelocity_r10':
../../asn1/lte-rrc/packet-lte-rrc-fn.c:17076: warning: implicit declaration of function 'dissect_lpp_HorizontalVelocity_PDU'
make[5]: *** [packet-lte-rrc.lo] Error 1

Ciao
     Jörg
as I indicated in bug 6742, Anders forgot to commit the newly added
asn1/lpp/packet-lpp-template.h and epan/dissectors/packet-lpp.h files
that are part of the patch.

Regards,
Pascal.
Sorry about that, I didn't notice the new file. Hopefully it should all be there now.
Regards
Anders
___________________________________________________________________________
Sent via:    Wireshark-dev mailing list<[email protected]>
Archives:    http://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://wireshark.org/mailman/options/wireshark-dev
              mailto:[email protected]?subject=unsubscribe