Wireshark-dev: Re: [Wireshark-dev] [Wireshark-commits] rev 21556: /trunk/epan/ /trunk/epan/: pr
From: Ulf Lamping <[email protected]>
Date: Tue, 24 Apr 2007 23:05:09 +0200
Anders Broman wrote:
I have no problem with backing out my changes but a
Proto_... function should not be local to iuup in my opinion.
Perhaps it should be renamed iuup_proto_.. instead until
We have "the real thing" in proto.c

What do others think?
Well, first of all, we shouldn't have a buildbot going into deep red for a long time, so there's something to be done.
I'll fully agree that a function starting with proto_ shouldn't be in 
any dissector code - a name clash will be the result sooner or later - 
and today is sooner ;-)
Could you please:

1.) fix the issue in iuup by prepending iuup_ so the buildbot get's green again - I'm currently waiting for it :-( 2.) if your new function doesn't follow the common function pattern, fix this issue in your implementation (I didn't had a look at the code in proto myself) 3.) change iuup to use the new function in proto.h (probably has to be done by someone else than you)
Regards, ULFL