Wireshark-bugs: [Wireshark-bugs] [Bug 5977] Automatic fuzztest not possible with openSAFETY when
Date: Wed, 1 Jun 2011 01:57:48 -0700 (PDT)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5977

Roland Knall <[email protected]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
   Attachment #6432|review_for_checkin?         |
               Flag|                            |
   Attachment #6432|0                           |1
        is obsolete|                            |
   Attachment #6435|                            |review_for_checkin?
               Flag|                            |

--- Comment #3 from Roland Knall <[email protected]> 2011-06-01 01:57:43 PDT ---
Created an attachment (id=6435)
 --> (https://bugs.wireshark.org/bugzilla/attachment.cgi?id=6435)
Handling of SercosIII if the plugin can not be loaded

Changed the behaviour - if the SercosIII plugin is not available, the
openSAFETY dissector registers itself for ETHERTYPE_SERCOS. SercosIII packages
can not be dissected anyway in such a case and currently no other dissector
will handle those packages.

The following steps will be taken to display the situation to the user:

The message "SercosIII dissector not available, openSAFETY/SercosIII native
dissection." will be added to the tree. Additionally a similar warning will be
presented on the console during startup of wireshark.

All openSAFETY packages will be dissected, displaying the normal openSAFETY
information.

This will be more transparent for the customer

-- 
Configure bugmail: https://bugs.wireshark.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.