5.12. Lua (Optional)

The Lua library is used to add scripting support to Wireshark. Wireshark 4.2.x and earlier support Lua versions 5.1 and 5.2. More recent versions of Wireshark require Lua 5.3 or later.

Unix

If this library isn’t already installed or available as a package for your platform, you can get it at https://www.lua.org/download.html.

Windows

We provide packages for Windows at https://dev-libs.wireshark.org/windows/packages/. The versions prior to 5.5.0 (shipped with Wireshark prior to 5.0) are patched to support UTF-8 regardless of the Windows code page. Starting with Lua the packages are not patched, and intended for Wireshark 5.0 and later, which use an application manifest to enforce that the Windows code page is 65001, i.e., UTF-8.