wnpa-sec-2010-04 · DOCSIS vulnerabilities in Wireshark

Summary

Name: DOCSIS vulnerabilities in Wireshark

Docid: wnpa-sec-2010-04

Date: May 5, 2010

Affected versions: {{ start_version }} up to and including {{ end_version }}

Related: wnpa-sec-2010-03 (DOCSIS vulnerabilities in Wireshark version 0.9.6 to 1.0.12)

Fixed versions: 1.2.8

Related: wnpa-sec-2010-03 (DOCSIS vulnerabilities in Wireshark version 0.9.6 to 1.0.12)

Details

Description

Wireshark 1.2.8 fixes the following vulnerability:

Impact

It may be possible to make Wireshark crash by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.2.8 or later.

If are running Wireshark 1.2.7 or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the affected dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "DOCSIS" is un-checked.
    • Click "Save", then click "OK".
Enhance Wireshark

Riverbed is Wireshark's primary sponsor and provides our funding. They also make great products.

Troubleshoot your Network

Free 30 day trial

Free 30 day trial

  • Save hours on network and application issue diagnoses
  • Monitor physical and virtual environments
  • GUI packet capture and analysis
  • Fully integrated with Wireshark

Try Cascade Shark VE & Cascade Pilot Free for 30 Days

802.11 Packet Capture

Riverbed AirPcap
  • WLAN packet capture and transmission
  • Full 802.11 a/b/g/n support
  • View management, control and data frames
  • Multi-channel aggregation (with multiple adapters)

Learn More

Buy Now

Packet Analysis Made Easy

    Cascade Pilot Personal Edition graphs
  • Visually rich, powerful LAN analyzer
  • Quickly access very large pcap files
  • Professional, customizable reports
  • Advanced triggers and alerts
  • Fully integrated with Wireshark

Try Cascade Pilot PE FREE for 10 days

Buy Now