wnpa-sec-2018-24 · Memory leaks in multiple dissectors

Summary

Name: Memory leaks in multiple dissectors

Docid: wnpa-sec-2018-24

Date: April 3, 2018

Affected versions: 2.4.0 to 2.4.5, 2.2.0 to 2.2.13

Fixed versions: 2.4.6, 2.2.14

References:
Wireshark issue 14480
Wireshark issue 14481
Wireshark issue 14482
Wireshark issue 14483
Wireshark issue 14484
Wireshark issue 14485
Wireshark issue 14486
Wireshark issue 14487
Wireshark issue 14488
Wireshark issue 14489

Details

Description

Multiple dissectors and other modules could leak memory. The TN3270, ISUP, LAPD, SMB2, GIOP, ASN.1, MIME multipart, H.223, and PCP dissectors were affected along with Wireshark and TShark. Discovered by Otto Airamo and Antti Levomäki, Forcepoint.

Impact

It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 2.4.6, 2.2.14 or later.