Huge thanks to our Platinum Members Endace and LiveAction,
and our Silver Member Veeam, for supporting the Wireshark Foundation and project.

wnpa-sec-2010-13 · LDSS vulnerability in Wireshark


Name: LDSS vulnerability in Wireshark

Docid: wnpa-sec-2010-13

Date: November 18, 2010

Affected versions: 1.2.0

Fixed versions: 1.2.13



Wireshark 1.2.13 fixes the following vulnerability:

  • Nephi Johnson of BreakingPoint discovered that the LDSS dissector could overflow a buffer. (Bug 5318) Versions affected: 1.2.0 to 1.2.12 and 1.4.0 to 1.4.1. CVE-2010-4300


It may be possible to make Wireshark crash by injecting a series of malformed packets onto the wire or by convincing someone to read a malformed packet trace file.


Upgrade to Wireshark 1.2.13 or later.

If are running Wireshark {{ end_version }} or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the LDSS dissector:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "LDSS" is un-checked.
    • Click "Save", then click "OK".