wnpa-sec-2010-02 · LWRES vulnerability in Wireshark


Name: LWRES vulnerability in Wireshark

Docid: wnpa-sec-2010-02

Date: January 27, 2010

Affected versions: {{ start_version }} up to and including {{ end_version }}

Fixed versions: 1.2.6



Wireshark 1.2.6 fixes the following vulnerabilities:

  • Babi discovered several buffer overflows in the LWRES dissector.
    Versions affected: 0.9.15 to 1.0.10, 1.2.0 to 1.2.5


It may be possible to make Wireshark crash remotely or by convincing someone to read a malformed packet trace file.


Upgrade to Wireshark 1.2.6 or later.

If are running Wireshark 1.2.5 or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the LWRES dissector:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "LWRES" is un-checked.
    • Click "Save", then click "OK".