wnpa-sec-2010-01 · Multiple vulnerabilities in Wireshark


Name: Multiple vulnerabilities in Wireshark

Docid: wnpa-sec-2010-01

Date: January 27, 2010

Affected versions: 0.9.0 up to and including 1.0.10

Fixed versions: 1.0.11



Wireshark 1.0.11 fixes the following vulnerabilities:

  • The SMB and SMB2 dissectors could crash. (Bug 4301)
    Versions affected: 0.9.0 to 1.0.10, 1.2.0 to 1.2.4 CVE-2009-4377 The Infiniband dissector could crash on some platforms.
    Versions affected: 1.0.6 to 1.0.10, 1.2.0
  • Babi discovered several buffer overflows in the LWRES dissector.
    Versions affected: 0.9.15 to 1.0.10, 1.2.0 to 1.2.5


It may be possible to make Wireshark crash remotely or by convincing someone to read a malformed packet trace file.


Upgrade to Wireshark 1.0.11 or later.

If are running Wireshark {{ end_version }} or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the affected dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "RADIUS" and "DCERPC" are all un-checked.
    • Click "Save", then click "OK".