wnpa-sec-2009-06 · Multiple vulnerabilities in Wireshark

Summary

Name: Multiple vulnerabilities in Wireshark

Docid: wnpa-sec-2009-06

Date: September 15, 2009

Affected versions: {{ start_version }} up to and including {{ end_version }}

Fixed versions: 1.2.2

Details

Description

Wireshark 1.2.2 fixes the following vulnerabilities:

  • The GSM A RR dissector could crash. (Bug 3893)
    Versions affected: 1.2.0 to 1.2.1
  • The OpcUa dissector could use excessive CPU and memory. (Bug 3986)
    Versions affected: 0.99.6 to 1.0.8, 1.2.0 to 1.2.1
  • The TLS dissector could crash on some platforms. (Bug 4008)
    Versions affected: 1.2.0 to 1.2.1

Impact

It may be possible to make Wireshark crash remotely or by convincing someone to read a malformed packet trace file.

Resolution

Upgrade to Wireshark 1.2.2 or later.

If are running Wireshark 1.2.1 or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the affected dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "GSM CCCH", "OpcUa", and "SSL" are all un-checked.
    • Click "Save", then click "OK".