ANNOUNCEMENT: Live Wireshark University & Allegro Packets online APAC Wireshark Training Session
July 17th, 2024 | 10:00am-11:55am SGT (UTC+8) | Online

wnpa-sec-2009-06 · Multiple vulnerabilities in Wireshark


Name: Multiple vulnerabilities in Wireshark

Docid: wnpa-sec-2009-06

Date: September 15, 2009

Affected versions: 0.99.6 up to and including 1.2.1

Fixed versions: 1.2.2



Wireshark 1.2.2 fixes the following vulnerabilities:

  • The GSM A RR dissector could crash. (Bug 3893)
    Versions affected: 1.2.0 to 1.2.1
  • The OpcUa dissector could use excessive CPU and memory. (Bug 3986)
    Versions affected: 0.99.6 to 1.0.8, 1.2.0 to 1.2.1
  • The TLS dissector could crash on some platforms. (Bug 4008)
    Versions affected: 1.2.0 to 1.2.1


It may be possible to make Wireshark crash remotely or by convincing someone to read a malformed packet trace file.


Upgrade to Wireshark 1.2.2 or later.

If are running Wireshark {{ end_version }} or earlier (including Ethereal) and cannot upgrade, you can work around each of the problems listed above by doing the following:

  • Disable the affected dissectors:
    • Select Analyze→Enabled Protocols... from the menu.
    • Make sure "GSM CCCH", "OpcUa", and "SSL" are all un-checked.
    • Click "Save", then click "OK".