Wireshark-users: Re: [Wireshark-users] Firefox not logging into $SSLKEYLOGFILE
From: Lee <[email protected]>
Date: Thu, 31 Oct 2019 09:27:05 -0400
On 10/31/19, Miroslav Rovis wrote:
> Hi!
>
> Regularly installed, recently:
>
> $ firefox --version
> Mozilla Firefox 70.0
>
> On Devuan (just a non-systemd Debian, 99% plus of packages are Debian):

Seems to be on purpose:
  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=842292
  In previous versions of libnss, it was possible to use SSLKEYLOGFILE
environment variable to save session keys to a file. Since version
3.24, this is disabled by default at compile time [1].

Regards,
Lee

>
> $ lsb_release -a
> No LSB modules are available.
> Distributor ID: Debian
> Description:    Devuan GNU/Linux 3 (beowulf)a
> [...]
>
> What else?...
>
> # apt-cache policy libnss3-dev
> libnss3-dev:
>   Installed: 2:3.47-1
>   Candidate: 2:3.47-1
>
> It just does not write any keys to my $SSLKEYLOGFILE.
>
> And maybe also this (although there's no keys, so FF gives no work to
> Wireshark):
>
> $ wireshark --version
> Wireshark 3.0.5 (Git v3.0.5 packaged as 3.0.5-1)
>
> Copyright 1998-2019 Gerald Combs <[email protected]> and contributors.
> License GPLv2+: GNU GPL version 2 or later
> <http://www.gnu.org/licenses/old-licenses/gpl-2.0.html>
> This is free software; see the source for copying conditions. There is NO
> warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
>
> Compiled (64-bit) with Qt 5.11.3, with libpcap, with POSIX capabilities
> (Linux),
> with libnl 3, with GLib 2.60.6, with zlib 1.2.11, with SMI 0.4.8, with
> c-ares
> 1.15.0, with Lua 5.2.4, with GnuTLS 3.6.9 and PKCS #11 support, with Gcrypt
> 1.8.5, with MIT Kerberos, with MaxMind DB resolver, with nghttp2 1.39.2,
> with
> LZ4, with Snappy, with libxml2 2.9.4, with QtMultimedia, with SBC, with
> SpanDSP,
> without bcg729.
>
> Running on Linux 5.4.0-rc4, with AMD Phenom(tm) II X4 965 Processor, with
> 7926
> MB of physical memory, with locale en_GB.UTF-8, with libpcap version 1.9.1
> (with
> TPACKET_V3), with GnuTLS 3.6.9, with Gcrypt 1.8.5, with zlib 1.2.11, binary
> plugins supported (0 loaded).
>
> Built using gcc 9.2.1 20190909
>
> All this is stock Debian packages, via Devuan servers IIUC.
>
> Anybody else has such an issue?
>
> --
> Miroslav Rovis
> Zagreb, Croatia
> https://www.CroatiaFidelis.hr
>