Wireshark-users: Re: [Wireshark-users] CentOS 6.3 and DUMPCAP -B option
From: John Powell <jrp999@xxxxxxxxx>
Date: Thu, 9 Aug 2012 07:56:55 -0600
Hi Jeff,

THANKS so much for your guidance- I have never done something like this before and it is pretty cool that is worked.

I was looking in the Source directory for 1.8.1 and did not see a SPEC file.

For future reference, I would like to know how to determine the requirements as the Config.Log file seemed too cryptic for me but I have had experience with SPEC files.  Could you enlighten me?

Thanks again for your help!


On Wed, Aug 8, 2012 at 2:04 PM, Jeff Morriss <jeff.morriss.ws@xxxxxxxxx> wrote:
John Powell wrote:
*Jeff,* I tried to install a later version of wireshark 1.4 on my 6.3 box but ran into issues with GTK+ and others

checking for GTK+ - version >= 2.4.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: GTK+ 2.4 or later isn't available, so Wireshark can't be compiled

    * I am new at the whole linux game, would it be possible for you to

      send me details on how the later version of Wireshark got
      installed on your 6.1 CentOS machine?
    * I am assuming it was installed from source and not from a

      repository, but if it was from a repository could you let me know
      which one?

You'd have to check the config.log to find out the exact reason, but CentOS 6 comes with GTK 2.18.9 so it should be fine.  Chances are you're missing the -devel package: "yum install gtk2-devel" to fix that.

(In fact I've also built 1.8.1 on CentOS 6; you might want to consider using this latest/great version too.)

There may be other -devel packages you need too.  The Fedora Core 17 Wireshark spec file (which builds 1.6.6) requires all of these packages to build; you don't need all of them (depending on what options you want), but it's a starting point (I added some comments):

BuildRequires:  libpcap-devel >= 0.9
BuildRequires:  libsmi-devel # only needed for SNMP
BuildRequires:  zlib-devel, bzip2-devel
BuildRequires:  openssl-devel # Not used by Wireshark any more
BuildRequires:  glib2-devel, gtk2-devel
BuildRequires:  elfutils-devel, krb5-devel # latter is optional
BuildRequires:  python, pcre-devel, libselinux # pcre-devel is optional, don't think you really need libselinux
BuildRequires:  gnutls-devel # only needed if you want to decrypt things
BuildRequires:  flex, bison, python, python-devel # python-devel only needed if you want Python scripting support (which doesn't work very well)
BuildRequires:  GeoIP-devel # only if you want GeoIP
BuildRequires:  libcap-devel # only if you want to use Linux Capabilities
BuildRequires:  adns-devel # optional
BuildRequires:  c-ares-devel # optional
BuildRequires:  portaudio-devel # optional
BuildRequires:  lua-devel #optional

Sent via:    Wireshark-users mailing list <wireshark-users@xxxxxxxxxxxxx>
Archives:    http://www.wireshark.org/lists/wireshark-users
Unsubscribe: https://wireshark.org/mailman/options/wireshark-users