ANNOUNCEMENT: Live Wireshark University & Allegro Packets online APAC Wireshark Training Session
April 17th, 2024 | 14:30-16:00 SGT (UTC+8) | Online

Wireshark-users: Re: [Wireshark-users] W2000 SP4 Wireshark 1.2.6 and 1.3.3 do not work

From: Julian Fielding <jfielding@xxxxxxxxxxxxxxx>
Date: Fri, 26 Mar 2010 12:42:10 +0100

On Wed, 24 Mar 2010 10:07:17 -0700, Gerald Combs wrote:
>Graham Bloice wrote:
>> On 23/03/2010 16:47, Mail Box wrote:
>>> It has already been reported by another user but has been erroneously closed as resolved.
>>> That is not the case.
>>> The reported error persists at least on some installations of W2000 SP4.
>>> Wireshark 1.2.5 works on the same platform.
>>>
>>> Error:
>>> "The procedure entry point getaddrinfo could not be located in the dynamic link
>>> library W32_32.dll"
>>>  
>> This call is made from the c-ares library, not wireshark itself.  
>> According to MSDN
>> (http://msdn.microsoft.com/en-us/library/ms738520%28VS.85%29.aspx, see
>> blurb near bottom on older versions of Windows) to use this function on
>> Windows < XP SP2 requires one to include ws2tcpip.h and Wspiapi.h before
>> using the function.  This then uses an in-line copy of the function if
>> the system dll doesn't include it.  This would mean building our own
>> copy of c-ares.
>>
>> As all MS support for W2K ceases on 13 July 2010
>> (http://support.microsoft.com/lifecycle/search/default.aspx?sort=PN&alpha=Windows+2000&Filter=FilterNO)
>> is this worthwhile?
>
>1.2.7 will restore Windows 2000 support. It is scheduled for release on
>March 31. In the meantime you can get a prerelease version from
>http://www.wireshark.org/download/prerelease/

The prereleases do run on Win2000, but they exhibit bug 4449 (ridiculous behaviour on opening Capture Interfaces or Options dialogs) (tested up to wireshark-win32-1.2.7pre1-32260.exe). I suggest staying with 1.2.5 for the moment.