ANNOUNCEMENT: Live Wireshark University & Allegro Packets online APAC Wireshark Training Session
April 17th, 2024 | 14:30-16:00 SGT (UTC+8) | Online

Wireshark-users: [Wireshark-users] Mac OS X Snow Leopard Wireshark 1.2.6 Crash at Startup (EXC_BA

Date: Mon, 22 Mar 2010 15:09:31 -0400
I've got one MacBook Pro that cannot run Wireshark while others can. When Wireshark is launched, I get the Wireshark logo in the dock for a second or two and then it goes away.

The crash log always shows the same thing

Process:         wireshark-bin [10455]
Path: /Applications/Wireshark.app/Contents/Resources/bin/wireshark-bin
Identifier:      wireshark-bin
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  Wireshark [10453]

Date/Time:       2010-03-22 15:05:27.236 -0400
OS Version:      Mac OS X 10.6.2 (10C540)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000008a514900
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libfontconfig.1.dylib           0x0398087e FcStrListCreate + 57
1   libfontconfig.1.dylib           0x0397a1ee FcLangSetHasLang + 506
2   libfontconfig.1.dylib           0x0397bd89 FcCompareLang + 149
3   libfontconfig.1.dylib           0x0397b910 FcCompareValueList + 448
4   libfontconfig.1.dylib           0x0397bb79 FcCompare + 180
5   libfontconfig.1.dylib           0x0397bf3e FcFontSetSort + 391
6   libfontconfig.1.dylib           0x0397c464 FcFontSort + 99

I looked at some of the bug reports and it seems a similar issue was identified with an early 1.2 release, but was fixed. I've redownloaded and installed 1.2.6 just to triple check I'm running that version...

Other X11 apps, like GIMP, run just fine.

Any suggestions?  Thanks in advance.

... Altan