Wireshark-users: [Wireshark-users] I've "officially" dropped support for Windows NT 4.0 ...
From: Ulf Lamping <[email protected]>
Date: Fri, 23 Feb 2007 21:24:08 +0100
Hi List!

After a long time, I "felt" that it was time to drop support for Windows NT 4.0!

The reasons for this step were:

- Microsoft itself dropped support for Windows NT 4.0 at the end of 2005, see http://www.microsoft.com/technet/archive/winntas/ntendlife.mspx?mfr=true - the libraries we use (e.g. GTK 2.x) seem to currently drop support for NT 4.0 as well - none of the developers seems to work / test on NT 4.0 any longer - and therefore is interested in spending any effort
So I've changed the following:

- the Windows installer won't install on NT 4.0 and just quits with a warning in this case (just as it does for Win9x based systems already today) - the User's Guide "System Requirements" section notes that NT 4.0 is no longer supported (well, it noted that already before)

However, support for NT 4.0 wouldn't be impossible even in the future - there's only no one willing to spend the required effort to keep it work. Running Wireshark on NT 4.0 - at least on the GTK1 port - should be possible for the foreseeable future - with some effort of a skilled developer.

As there seems to be more desirable goals to spend effort than supporting NT 4.0, the support has dropped in effect from 0.99.5 ...
Regards, ULFL


P.S: Don't flame me on this decision, as long as you are willing to do the actual work yourself!