Wireshark-users: Re: [Wireshark-users] installation of wireshark 0.99.3, checkinstall : argument
From: Jeff Morriss <[email protected]>
Date: Fri, 15 Sep 2006 09:36:22 +0800

Janssens, Kitty wrote:
I've downloaded the wireshark 0.99.3 version of the 24th of august 2006 and tried to install it (on solaris 9)
The result :
# pkgadd -d wireshark-0.99.3-SVN-18976-solaris2.9-sparc-local The following packages are available:
  1  wireshark     wireshark 0.99.3-SVN-18976
                   (sparc) 0.99.3-SVN-18976
Select package(s) you wish to process (or 'all' to process
all packages). (default: all) [?,??,q]:
Processing package instance <wireshark> from </export/home/userhome/be083316/temp/wireshark-0.99.3-SVN-18976-solaris2.9-sparc-local> wireshark 0.99.3-SVN-18976
(sparc) 0.99.3-SVN-18976
Wireshark Development Team
## Executing checkinstall script.
/tmp/installngaaTW/checkinstallqgaaTW: test: argument expected
pkgadd: ERROR: checkinstall script did not complete successfully
Installation of <wireshark> failed.
No changes were made to the system.
#
Can anyone help me with this ?
I saw this too when I used wireshark.org's Solaris 9 package; IIRC 
(don't have access to check now) the problem is related to the location 
the package is expecting your GTK libraries to be in vs. where they 
actually are.  Or something like that...  You can check what the 
'checkinstall' script is doing by looking inside the package itself if 
you are so inclined.
In the end I built my own package (but I usually do anyway).