Wireshark-dev: Re: [Wireshark-dev] macOS dark mode in 3.0.0
From: Lori Jakab <[email protected]>
Date: Thu, 21 Mar 2019 15:08:50 +0100
On Thu, Mar 21, 2019 at 11:23 AM Roland Knall <[email protected]> wrote:
>
> Ok, upon further investigation, my comment may not be entirely accurate, it appears that you need to build also with the macOs 10.14+ SDK to enable the dark mode (see https://bugreports.qt.io/browse/QTBUG-68850?focusedCommentId=408457&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-408457). Not sure, if our build-system does that, as it needs to support also older version of MacOS.

OK, I tried building latest master locally on my system. My Qt library
was install from Homebrew, and just to make sure that I have the
latest Mojave version, I reinstalled it. This is the package that was
installed: qt-5.12.2.mojave.bottle.tar.gz

I built Wireshark locally (I have XCode 10.1 (10B61)), and still no
joy. I can't find anything related to dark mode in the CMake options.
Did anyone manage to build a dark mode enabled version successfully?

Thanks,
-Lori

>
> Anyone got an idea, which SDK version we are using?
>
> regards
> Roland
>
> Am Do., 21. März 2019 um 09:43 Uhr schrieb Lori Jakab <[email protected]>:
>>
>> Hi,
>>
>> I'm on macOS Mojave using dark mode, and my understanding was that
>> Wireshark 3 does support it. Is there anything that needs to be done
>> to activate it? For me it still shows up with light color palette.
>>
>> About:
>>
>> Version 3.0.0 (v3.0.0-0-g937e33de)
>>
>> Copyright 1998-2019 Gerald Combs <[email protected]> and
>> contributors. License GPLv2+: GNU GPL version 2 or later
>> <http://www.gnu.org/licenses/old-licenses/gpl-2.0.html> This is free
>> software; see the source for copying conditions. There is NO warranty;
>> not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
>>
>> Compiled (64-bit) with Qt 5.12.1, with libpcap, without POSIX
>> capabilities, with GLib 2.37.6, with zlib 1.2.8, with SMI 0.4.8, with
>> c-ares 1.15.0, with Lua 5.2.4, with GnuTLS 3.4.17, with Gcrypt 1.7.7,
>> with MIT Kerberos, with MaxMind DB resolver, with nghttp2 1.21.0, with
>> LZ4, with Snappy, with libxml2 2.9.9, with QtMultimedia, with SBC,
>> with SpanDSP, with bcg729.
>>
>> Running on Mac OS X 10.14.3, build 18D109 (Darwin 18.2.0), with
>> Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz (with SSE4.2), with 16384 MB
>> of physical memory, with locale C, with libpcap version 1.8.1 -- Apple
>> version 79.200.4, with GnuTLS 3.4.17, with Gcrypt 1.7.7, with zlib
>> 1.2.11, binary plugins supported (14 loaded). Built using clang 4.2.1
>> Compatible Apple LLVM 10.0.0 (clang-1000.11.45.5).
>>
>> Thanks,
>> -Lori
>> ___________________________________________________________________________
>> Sent via:    Wireshark-dev mailing list <[email protected]>
>> Archives:    https://www.wireshark.org/lists/wireshark-dev
>> Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
>>              mailto:[email protected]?subject=unsubscribe
>
> ___________________________________________________________________________
> Sent via:    Wireshark-dev mailing list <[email protected]>
> Archives:    https://www.wireshark.org/lists/wireshark-dev
> Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
>              mailto:[email protected]?subject=unsubscribe