Wireshark-dev: Re: [Wireshark-dev] No interfaces showing (Win 10, WS 3.0)
From: Graham Bloice <[email protected]>
Date: Mon, 18 Mar 2019 16:48:00 +0000
What is the contents of the Wireshark -> Help -> About Wireshark -> Wireshark dialog?  You can highlight the text and copy it and paste it into your reply.  You could also use the output of "tshark --version".



On Mon, 18 Mar 2019 at 15:53, David Kozinn <[email protected]> wrote:

Hi Devs,

 

I’m using Version 3.0.0 (v3.0.0-0-g937e33de) on Windows 10 Pro 64-bit 1903 (build 18356.1), and there are no interfaces at all showing when I start Wireshark. WinDump -D shows:

 

1.\Device\NPF_{C0E23443-4215-4E51-8016-633F44FC063E} (Realtek PCIe GBE Family Controller)

2.\Device\NPF_{AA3C112A-73F5-420E-8078-6C4B7CDA69C5} (Microsoft)

3.\Device\NPF_{362B3BBF-C171-4125-A3DF-817B31E4F7E1} (Microsoft Corporation)

4.\Device\NPF_{B4422FE7-42C4-4285-83E1-03D6840FAB0C} (Microsoft)

5.\Device\NPF_{04833D28-6756-4E4E-874F-F6F1328063D0} (Microsoft)

6.\Device\NPF_{D5400C59-3FD8-4B91-82AA-827B3E155B85} (TAP-Windows Adapter V9)

7.\Device\NPF_{6562DFC2-4BF3-4007-BDC4-7A2249032205} (Microsoft)

 

If I run windump on interface 3 I see traffic.

 

I know that 3.0 worked after I initially installed it, however I don’t know if it worked after the first reboot after that, and I have subsequently received Windows 10 updates (I’m on the Insider Slow ring). I’ve rebooted several times with no change.

 

For what it’s worth, Microsoft Netmon does display the interfaces and capture traffic, though I realize that’s not via npcap.

 

I’d appreciate any help.

 

Thanks,

 

David

___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <[email protected]>
Archives:    https://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
             mailto:[email protected]?subject=unsubscribe


--
Graham Bloice
Software Developer
Trihedral UK Limited