Wireshark-dev: [Wireshark-dev] Wireshark seems to require Python 3.4 or better now ...
From: Richard Sharpe <[email protected]>
Date: Sat, 10 Nov 2018 09:32:31 -0800
Hi folks,

I am running into problems with building the latest Wireshark master
release on CentOS 7.5.1804.

Wireshark seems to need Python 3.4 or better, and I have Python 3.6
installed and am using the software collection (scl enable rh-python36
bash) but cmake 3 does not want to find it.

I get:

   [[email protected] wireshark-build]$ python -V
   Python 3.6.3
   cmake3 ../wireshark-official
   ...
   CMake Error at
/usr/share/cmake3/Modules/FindPackageHandleStandardArgs.cmake:137
(message):
     Could NOT find PythonInterp: Found unsuitable version "2.7.5", but required
     is at least "3.4" (found /usr/bin/python)

Any suggestions?

-- 
Regards,
Richard Sharpe
(何以解憂?唯有杜康。--曹操)(传说杜康是酒的发明者)