Wireshark-dev: [Wireshark-dev] Windows development - Qt and WSDG updates?
From: "Maynard, Chris" <[email protected]>
Date: Mon, 15 Oct 2018 15:44:03 +0000
VS2017 is used by both the 64-bit and 32-bit buildbots, and both use Qt 5.9.5.
 
Qt 5.9.6 has been available since June 2018[1] and 5.9.7 is supposedly due last month – should the buildbots be updated to 5.9.6 or 5.9.7 when it’s released?  Of course, the next LTS release, Qt 5.12, is due to be released at the end of November[2], so maybe the plan is to just move to Qt 5.12 instead?  Maybe that’s a good plan for Wireshark 3.0?
 
Also, I think the developer guide needs some clarification as it states the following:
 
Note that installation of separate Qt components are required for 32 bit and 64 bit builds, e.g. “msvc2017 32-bit” and “msvc2017 64-bit”. The environment variable QT5_BASE_DIR should be set as appropriate for your environment and should point to the Qt directory that contains the bin directory, e.g. C:\Qt\5.9.5\msvc2017_64
 
There is no msvc2017 32-bit option, and this is also reflected in the buildbots, as they set the following:
 
The 64-bit buildbot sets QT5_BASE_DIR=C:\Qt\5.9.5\msvc2017_64
The 32-bit buildbot sets QT5_BASE_DIR=C:\Qt\5.9.5\msvc2015
 
It seems that the text should read, “msvc2015 32-bit” instead, no?
- Chris
 
 
 
 
 
 
 
 
 
 
 
 
CONFIDENTIALITY NOTICE: This message is the property of International Game Technology PLC and/or its subsidiaries and may contain proprietary, confidential or trade secret information. This message is intended solely for the use of the addressee. If you are not the intended recipient and have received this message in error, please delete this message from your system. Any unauthorized reading, distribution, copying, or other use of this message or its attachments is strictly prohibited.